Where can I find my version information and logs?

PDF for offline use

Let us know how you feel about this

Translation Quality


0/250

Outline

Version information

It's usually best to send back all of the information from the Copy Information buttons. Otherwise we will often need to request additional information. For example, operating system versions, Xcode version, installed Android API levels, and .NET version can all be important when helping to troubleshoot a problem.

Windows version information

Xamarin Studio

Help > About > Show Details > Copy Information [button]

Visual Studio

Help > About Microsoft Visual Studio > Copy Info [button]

Mac version information

Xamarin Studio

Xamarin Studio > About Xamarin Studio > Show Details > Copy Information [button]

Android SDK Tools, Platform-tools, Build-tools

Open the Android SDK Manager, and take a screenshot of the top Tools section.
Screenshot of the Android SDK Manager -> Tools folder

Xamarin Studio

Tools > Open Android SDK Manager

Visual Studio

Select the SDK Manager toolbar icon:
"Start Android SDK Manager" toolbar icon in Visual Studio

IDE and installer logs

For each log location, be sure to zip up and attach the entire log folder.

Windows logs

You can copy and paste any of these paths into the location bar in Explorer.

Xamarin Studio

%LOCALAPPDATA%\XamarinStudio-5.0\Logs

This folder can also be opened via Help > Open Log Directory.

Xamarin for Visual Studio

%LOCALAPPDATA%\Xamarin\Logs

Xamarin "Universal" installer

%LOCALAPPDATA%\Xamarin\Universal

These are the logs from the XamarinInstaller.exe installer.

Individual .msi installers, verbose logs

msiexec /i Xamarin.msi /l*vx "%USERPROFILE%\Desktop\Xamarin.log"

Reference: Command-Line Options

Visual Studio startup, verbose logs

devenv.exe /log "%USERPROFILE%\Desktop\VisualStudio.log"

Reference: /Log (devenv.exe)

Mac logs

You can select the Go > Go to Folder menu item in Finder, and then copy and paste any of these paths into the dialog.

Build host

~/Library/Logs/Xamarin-4.0

Xamarin Studio

~/Library/Logs/XamarinStudio-5.0

This folder can also be opened via "Help -> Open Log Directory".

Xamarin "Universal" installer

~/Library/Logs/XamarinInstaller/Universal

These are the logs from the XamarinInstaller.dmg installer.

Verbose build output

  1. Enable diagnostic MSBuild output.

  2. For iOS apps, also enable verbose mtouch output by adding -v -v -v -v under Project Properties > iOS Build > General [tab] > Additional Options > Additional mtouch arguments.

    Project Properties -> iOS Build -> General -> Additional Options -> Additional mtouch arguments: -v -v -v -v

    Xamarin Studio, Project Options -> iOS Build -> General -> Additional Options -> Additional mtouch arguments: -v -v -v -v

  3. Clean and rebuild the project.

  4. Copy and paste the build output from the IDE into a text file.

    • Xamarin Studio: View > Pads > Errors > Build Output [tab]
    • Visual Studio: View > Output > Show output from: Build

Debug logs for Xamarin.Android and Xamarin.iOS apps

Xamarin Studio

View > Pads > Application Output
Xamarin Studio, View -> Pads -> Application Ouptut

(Note that this menu item will only appear after the app has been launched.)

Visual Studio

View > Output > Show output from: Debug
Visual Studio, View -> Output -> Show output from: Debug

Android adb logcat logs

After running the adb command, attach back the android_logcat.txt file from your Desktop. These instructions assume you have only one device attached.

See also: http://developer.xamarin.com/guides/android/deployment%2C_testing%2C_and_metrics/android_debug_log

Visual Studio

  1. Tools > Android > Start Android Adb Command Prompt
  2. Clean the log: adb logcat -c
  3. Reproduce the issue.
  4. Output the log: adb logcat -vtime -d > "%USERPROFILE%\Desktop\android_logcat.txt"

Xamarin Studio Windows

  1. Tools > Open Android SDK Command Prompt
  2. Clean the log: adb logcat -c
  3. Reproduce the issue.
  4. Output the log: adb logcat -vtime -d > "%USERPROFILE%\Desktop\android_logcat.txt"

Xamarin Studio Mac

  1. Tools > Open Android SDK Command Prompt
  2. Clean the log: adb logcat -c
  3. Reproduce the issue.
  4. Output the log: adb logcat -vtime -d > ~/Desktop/android_logcat.txt

iOS simulator logs (on Mac)

  • To access the system log, select Debug > Open System Log... in the iOS Simulator app.

    "Debug -> Open System Log..."

  • To view crash reports from the simulator, open Console.app and navigate to ~/Library/Logs > DiagnosticReports.

iOS device logs (on Mac)

Xamarin Studio

View > Pads > iOS Device Log

Xcode 6 and Xcode 7

Window > Devices > ${DeviceName}

Crash reports are available under the View Device Logs button. The system log for the device appears at the bottom of the window under the disclosure arrow Disclosure arrow.

Xcode 5

Window > Organizer > Devices [tab] > ${DeviceName}

Xamarin Workbook

If it's not already installed, install the Xamarin Workbooks app first. The workbook file should download automatically, but if it doesn't, just click to start the workbook download manually.