Connecting to TFS with Xamarin Studio Mac

PDF for offline use
Related Links:

Let us know how you feel about this

Translation Quality


0/250

last updated: 2015-11

Because Xamarin Studio does not natively support Team Foundation Server, Mac developers can install the Eclipse IDE and Microsoft's Team Explorer Everywhere (TEE) plugin for Eclipse, with which they can connect to TFS team projects. Eclipse and TEE together provide a visual interface that is nearly identical to Team Explorer in Visual Studio.

Installing Eclipse and the TEE Plugin

  1. Install the Eclipse IDE from http://www.eclipse.org. When you click the Download button, you'll see a variety of different versions to choose from. "Eclipse IDE for Java EE Developers" is the most common.
  2. Navigate to the Team Explorer Everywhere download page. Select the latest version, which which will be compatible with all released versions of TFS.
  3. When you click the Download link, you'll see three options. Select the zip file that begins with "TFSEclipsePlugin". (If desired, you can also select the TEE-CLC command line tools and the TFS-SDK for creating extensions for TFS.)
  4. In Eclipse, select the Help > Install New Software... menu command to display the Install screen:

  5. Click the Add… button to display the Add Repository screen:

  6. Click Local…, navigate Downloads, select the TFSEclipsePlugin folder, click Open, and then click OK.

  7. Check the box next to Team Explorer Everywhere, then click Next >:

  8. Review install details on the next screen, press Next > again, review and accept the licenses on the scree that follows, then click Finish to complete the installation:

  9. Restart Eclipse when prompted, and once restarted you'll be able to connect to TFS from the Mac as described in the next section.

Connecting to TFS with the TEE Plugin

  1. In Eclipse, select the Window > Show View > Other command and select Team Foundation Server > Team Explorer:

  2. In the Team Explorer pane, click Connect to Team Foundation Server:

  3. Review and accept the license if it appears, click Next, and the Add Existing Team project window (below) appears. Click Servers.

  4. In the Add/Remove Team Foundation Server dialog, click Add…, and enter the required connection information. Note that this dialog allows you to connect to a local TFS server (as shown), or you can connect to a Visual Studio Team Services server using its URL.

  5. Press OK, enter credentials when prompted, and you’ll return to the Add/Remove server window. Click Close to return to the Add Existing Team Project window.

  6. Make sure the desired server is selected from the top list so that its collections appear on the left. Select the desired collection and available Team Projects will appear on the right:

  7. Place a check by any Team Projects you'll be working on and click Finish.

Note: Mac users are not able to create new Team Projects through the plugin, they can only consume existing TFS-based Team Projects created in Visual Studio on a Windows machine. Mac users, however, can create new projects directly through the web portal. To visit the portal, click the Web Portal button in Team Explorer Everywhere:

Xamarin Workbook

If it's not already installed, install the Xamarin Workbooks app first. The workbook file should download automatically, but if it doesn't, just click to start the workbook download manually.